实战手记之Native Vlan与IVR

    2006-04-29
Keywords: 802.1Q Native Vlan Inter-Vlan Routing Show trunk Management
Vlan 之间的路由(Inter-Vlan Routing,这里简写为IVR)好象很简单,不过也有些窍门。比如一个常见的错误是使用802.1Q封装时,交换引擎与路由器之间的TRUNK两端的Native VLAN不匹配。如Catalyst 4006交换机与其路由模块WS-C4232_L3之间就使用802.1Q的TRUNK封装,在交换引擎上用set vlan 1 3/1设置trunk的Native Vlan,用show trunk命令查看;在L3模块上用enc dot1q n native来表示该VLAN是TRUNK的Native VLAN。
在TRUNK上Native VLAN的数据是无标记的(Untagged),所以即使没有在TRUNKING,Native Vlan上仍能正常通讯。show cdp nei detail可以检查Native VLAN不匹配的情况。没有特别的需要,Native VLAN最好使用默认的VLAN 1。3500交换机上如果更改了TRUNK的Native VLAN,管理端口也要相应地更改,如VLAN2: interface VLAN 2 , ip address ... , management。
在外接路由器如2620做router-on-a-stick的时候,也有一点小窍门:首先要有FastEthernet端口; 其次标准的IP软件不支持TRUNK,只有IP Plus以上的才支持。最后如果您使用的IOS不支持encapsulation dot1q 1 native这个“native”关键字的话,将Native Vlan的网关地址配置在主端口上,形式如:
interface fastethernet 0/0
ip address 10.1.1.254 255.255.255.0
speed auto
duplex auto
!
interface fastethernet 0/0.2
encapsulation dot1q 2
ip address 10.1.2.254 255.255.255.0
如果支持“native”关键字,则是:
interface fastethernet 0/0
no ip address
speed auto
duplex auto
!
interface fastethernet 0/0.1
encapsulation dot1q 1 native
ip address 10.1.1.254 255.255.255.0
!
interface fastethernet 0/0.2
encapsulation dot1q 2
ip address 10.1.2.254 255.255.255.0
最近在7609路由器上观察到一个奇怪的问题。7609由6509交换机改进而成,绝大多数硬件都跟6509一样,包括引擎,软件(CatOS+IOS),我想这个问题6500上也会有。现象是这样的,这台机器配了两个引擎,如果MSFC15配置如下:
interface vlan 1
ip address 10.1.1.254 255.255.255.0
!
interface vlan 2
ip address 10.1.2.254 255.255.255.0
而MSFC16只配置了VLAN2及默认路由:
interface vlan 2
ip address 10.1.2.253 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 10.1.2.254
则在VLAN 1内如地址为10.1.1.1的主机 ping不通 10.1.2.253,但能ping 通10.1.1.254及10.1.2.254。例外的是7609交换引擎在VLAN1内的管理地址,它能ping 通上述所有的地址。我想这个问题可能跟多层交换/CEF有关,哪位高手已经解决了这个问题?

如果您认为本网站提供的资料侵犯您的版权,请及时通知我们, 我们将及时加上版权信息或立即删除相关内容,并向您致以诚挚的歉意。
  • 2017年10月,中研网承建中山大学的“海外藏中国民俗文献与文物资料数据库技术平台(一期)”项目。主要用于存放资料的数据库架构和索引建立,能够展示、检索相关...
  • 2017年10月,中研网承建首都图书馆的“首都图书馆乡土文化研究问卷调查数据库系统开发”项目。首都图书馆是北京市大型公共图书馆,藏书超过350万册,文献借阅量逾...
  • 2017年11月,中研网承建中国民俗学会的“非物质文化遗产本体知识管理平台:2017年度数据跟踪采集建档”项目。中国民俗学会在2014年法国巴黎举办的联合国教科文组...
  • 2017年10月,中研网承建中国少数民族文学学会的“中国少数民族文学学会互联网应用平台开发项目”,中国少数民族文学学会成立于1979年,是由全国少数民族文学工作...
  • 2017年9月,中研网承接中国社会科学院民族文学研究所的“蒙古英雄史诗大系数字化建档开发项目”。中国社会科学院民族文学研究所从事各少数民族传统宗教、文化、社...
  • 2017年9月,由中研网承建了中国社会科学院民族文学研究所的“中国神话母题W编目数据库开发项目”的建设。由少数民族语言研究所与民族研究所合并形成了中国社会科...
蒙古英雄史诗大系 理想国 北京环保宣教中心 中国仪式音乐网 国家气象信息中心 THORPEX中国委员会 晁浩建声乐中心 中国民俗学网 中国石油造价信息网 国家气候中心 中科院电工研究所 中实联展 中国创业风险投资 中国科学技术战略研究院 中国气象学会-气象通信与信息技术委员会